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Turtle Python 1 – Getting Started 

1.  Introducing the Turtle System 

The Turtle System (or just Turtle for short) is a programming environment designed for ease of use and 

learning, offering three programming languages: 

• Turtle Python (the default) 

• Turtle BASIC 

• Turtle Pascal 

These are simplified versions of standard languages, which makes it easy to get started, more 

manageable for students (and teachers), and also enables Turtle to provide lots of help for beginners.  

For example, the error messages can be far more precise and straightforward than in an “industrial 

strength” system – enabling the vast majority of elementary errors to be sorted by the student without 

further help.  Another virtue of this simplicity is to enable straightforward comparison of the different 

languages (for example, by swapping between the example programs and seeing how they change 

between the languages).  This helps to demonstrate that programming in any language of this general 

type is essentially similar: what matters most is not the detailed “syntax” of the specific language, but 

rather the logic of the algorithms (i.e. the computational recipes) that the language expresses.  So it 

really doesn’t matter what programming language you start with: once you have developed the skill 

of thinking algorithmically, that skill can easily be transferred to another language, and you can use 

the same Turtle System to start learning it with minimal difficulty! 

2.  Downloading and Running the System 

Turtle can be downloaded free of charge from www.turtle.ox.ac.uk, and the main system consists of 

one executable program – named TurtleSystem_15.exe – which can be run from any folder on a PC 

(a version for Mac is planned for 2024).  No further installation is necessary, and the system will never 

make any secret changes to your computer setup. 

After you have moved the executable program to an appropriate directory (e.g. maybe “C:\Turtle”), 

you can run it simply by double-clicking on it within Windows Explorer.  At this point, if you have not 

run it before, you might get a warning saying “Windows protected your PC”, indicating that your 

system has identified a potential threat in the form of an unknown program.  Needless to say, we have 

no malicious software on www.turtle.ox.ac.uk, so you can safely click on the “More info” link and on 

the button that should appear saying “Run anyway”.  On running the program first time, you are also 

likely to see a dialog box headed “Setting Up Your Personal Turtle Directory”.  If you have no wish to 

experiment with file processing programs, it’s fine to click on “Continue without Turtle Directory”.  

Otherwise, select one of the three offered options and click on “Attempt to Set Up Selected Directory” 

– if, for example, you select the third option, then you should find that your “Turtle” directory now has 

a subdirectory called “Turtle Files”.  (Note that as a security measure and to avoid accidental 

modification of other computer files, the Turtle System will not allow your programs to process files 

that are not within a directory named “Turtle Files”.) 

When the system starts up, you should see at the left that it is running “PYTHON”, and that there are 

five menus to the right of this along the top, “File”, “Edit”, “View”, “Run”, “Options” and “Examples”.   

If you now click on the “View” menu and select “Simple Mode” (near the bottom), you will find that 

the “Options” menu disappears and all of the menus (except for “Examples”) become shorter.  The 

system supports four “Modes”, to enable non-expert users to be shielded from the more sophisticated 

facilities that they are unlikely to use and might find distracting or confusing.  
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3.  Starting with “Turtle Graphics” 

Staying in Simple Mode, click on the “Examples” menu and select the very first example program from 

the first sub-menu – it is called “Simple drawing with pauses”.  Now click on the “RUN” button (just 

below and a bit to the right of the menus).  You should then see something like this: 

The name of the Turtle System is derived from Seymour Papert’s invention of “turtle graphics” as a 

brilliant way to introduce programming to children (of all ages!).  Although originally associated with 

his programming language LOGO, this has proved so successful and popular that most standard 

languages now have at least one turtle graphics module available for learners (and often there are 

numerous versions, produced all over the world).  The idea is to imagine an invisible Turtle (though 

children’s systems will often provide a visible image) who starts off pointing “north” in the middle of a 

drawing “Canvas”, and is given drawing instructions by the written program.  In this case, when “RUN” 

is clicked, the Turtle is given the following instructions: 

colour(green) 

blot(100) 

pause(1000) 

colour(red) 

forward(450) 

pause(1000) 

circle(20) 

right(90) 

thickness(9) 

colour(blue) 

pause(1000) 

forward(300) 

(The first line of the program, “# draw green blot radius 100, then pause”, is a comment rather than 

an instruction – it’s included to make the program easier to understand.  If you want to delete all of 

the comments, select “Remove any comments” from the “Edit” menu, and note that if you then want 

to reverse this, use “Restore previous version” – at the bottom of that menu – rather than “Undo”.) 

You will see that the program has three pause(1000) instructions – pausing for 1000 

milliseconds (i.e. one second) each time – so when it runs you can see its progress in steps.  By the first 

pause, the Turtle has drawn a green blot (i.e. a filled green circle) of radius 100 in its original position 
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at the centre of the Canvas.  By the second pause, it has changed its pen colour to red and drawn a 

thin red line northwards, nearly reaching the top of the Canvas (1000×1000 units by default, so going 

north 450 units leaves the Turtle 50 units from the top).  Then it turns right by 90 degrees, changes its 

pen thickness to 9 (from the default of 2) and its pen colour to blue, pauses a third time, and finally 

draws a thick blue line 300 units long (pointing now towards the east, after its 90 degree turn).  Note 

that between the second and third pauses, the Canvas itself doesn’t change at all, but you can see the 

changes in the Turtle’s direction, pen thickness and colour in the information boxes above the Canvas.  

The values in these boxes can be used in your programs, using the names: 

 turtx the current x-coordinate of the Turtle 

 turty the current y-coordinate of the Turtle 

 turtd the current direction of the Turtle (expressed in “angle units”) 

 turta the number of “angle units” in a circle (by default, 360) 

 turtt the current thickness of the Turtle’s pen 

 turtc the current colour of the Turtle’s pen (expressed as an “RGB” colour code) 

We won’t be using any of these right now, but it’s helpful to remember that the current values of these 

Turtle attributes will affect, for example, where lines are drawn and in what colour etc.  Thus the effect 

of the instruction thickness(9), for example, is not to actually draw anything with that thickness, 

but just to change the Turtle’s current pen thickness attribute, turtt, to 9. 

4.  Canvas, Console, and Output 

Run that first program a few times until you are sure that you understand what it’s doing.  Another 

very simple program can be loaded by choosing “Skeleton program” from the “File” menu; this has just 

four instructions: 

print("Hello world!") 

var1=100 

colour(green) 

blot(var1) 

When you now click “RUN” you should see a familiar green blot in the centre of the Canvas, but also 

the text “Hello world!” in the Console beneath the Canvas: 
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Any text written to the Console is also standardly written also to the “Output” tab, which can be 

selected at the bottom right of the software window.  Try clicking on that, then immediately on “RUN” 

again.  You will see that running a program standardly brings you back to the “Canvas & Console” tab 

(though this behaviour can be changed, in more advanced system Modes, from the “Run” menu). 

 The point of the “Skeleton program” is to give a very simple example of a program, including 

a comment, a print instruction, the setting of a numeric variable (here called “var1”, and set to 100) 

and of the Turtle’s colour, and the drawing of a blot of the given size.  To appreciate the value of this, 

try selecting “Turtle Pascal” from the “LANGUAGE” menu: you are instantly into Pascal programming 

– with a comment, a print instruction, a defined and assigned variable etc. – without having to first 

learn for yourself about Pascal program structure.  Now go back to “Turtle Python”. 

5.  The Help Panels 

The two other tabs visible at the bottom right of the software window in Simple Mode are labelled 

“QuickHelp 1” and “QuickHelp 2”.  The first of these contains eight information panels, outlining in a 

very abbreviated way the main points of programming in Turtle Python.  This material is not primarily 

designed for learning, but rather as a useful prompt or reminder that can save a lot of time if you forget 

details while writing a program.  (These panels are also very helpful if, say, you want to quickly pick up 

the fundamentals of programming in another language, such as Turtle Pascal.) 

The “QuickHelp 2” tab is even more helpful, giving a summary of Turtle Python commands which will 

often be sufficient for you to use them effectively in your programs.  If you are in Simple Mode, then 

relatively few commands will be shown initially, but you can if you wish display all of the commands 

available, either alphabetically or (the default) arranged by function groups, starting with Turtle 

movement commands, then shape drawing commands, and so on.  The commands are also classified 

into “Simple”, “Intermediate”, and “Advanced”, but if you select both “Include all levels” and “Include 

all groups”, you will see the entire range.  More useful for advanced programmers is to “Include all 

levels” but to deselect “Include all groups” – after which the commands will all disappear from the 

table – and now select the particular function group that you are interested in, for example “Turtle 

moving/drawing instructions” or “Input and timing, and file processing”, as in the following images: 
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Here the “Type” column is relevant for functions that return a value, “Parameters” specifies the names 

and types of parameters (“i” integer, “s” string, “b” Boolean), and “PCode” indicates the corresponding 

machine code instruction.  The last of these is relevant only to those who wish to explore “Machine 

Mode” with its ability to see inside the virtual machine on which the Turtle System programs run.  

These facilities are not covered in the current series of Turtle Python teaching materials, but will be 

the subject of other materials – aimed at a A-Level audience – that are under development. 

6.  The Example Programs, and Configuring the System 

We have already seen one example program, but there are over 100 others, ranging from simple and 

more advanced graphics, to algorithmic structures and commands, interactive and animated 

programs, AI and strategy games, file handling, advanced algorithms, and a wide range of computer 

models from maths, physics, biology and other fields.  Many of the Turtle System teaching materials 

are structured around these, but as you progress, you are likely to find that more and more of these 

programs become accessible to you just by loading, examining and running them. 

 If you are a class teacher, then you might feel that having all these example programs available 

to your students is too distracting.  But fortunately, this is one of very many things that can be 

configured as you wish, by going into Expert mode and either selecting “Lock or restrict system setup” 

from the “Options” menu (or, more complex and versatile, using the two last options from the 

“Examples” menu).  Quite generally, you can set up the system as you wish in lots of respects, so that 

for example it starts in a particular programming language, with certain programming options selected 

(e.g. default Python indenting), and with particular menus, tabs, or example programs either available 

or hidden etc.  If you now go to the “Options” menu, fix the desired default Mode (with “Lock or restrict 

system setup”) and finally save a Default.tgo file to the Turtle directory (with “Save current settings to 

options file”), then your desired setup will take effect whenever the system starts up.  Among the 

possibilities provided by the “Lock or restrict system setup” dialog is to hide the facilities which enable 

these configuration options to be changed.  If the Turtle System is being run from a school network 

directory whose files cannot be edited or deleted by the students, then they will be unable to override 

the configuration set by Default.tgo when the system starts up.  Details of all this are available in the 

User Guide for Teachers available on the Turtle website through the “Documentation” link. 
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